Due to our host upgrading to php 7.0 our current forums are not compatible. I will be installing a new forum version as soon as possible. I hope to be able to import all users or you may have to register again. May also have to start fresh without existing content depending upon compatibility. Not sure if any of the add-ons will be available, such as chat.

Plunkin'